Ford Fiesta ST Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter · #1 ·
Circled in green - accessible from under the car and visible with open ended wrench (7mm)
Circled in red - accessible from above and connected to throttle body (2 clamps - 7mm open ended wrench)
Circled in yellow - blind clamps (can feel but not see - 1/4 inch drive ratchet and 7mm shallow socket)

Land vehicle Vehicle Car Auto part Engine
 

·
Registered
Joined
·
2,235 Posts

·
Registered
Joined
·
545 Posts
More from the original thread:


Looking towards the front of the car, on the passenger side.



On the passenger side of the intercooler:



Driver's side of the intercooler:



Close-up of the clamp closest to the intercooler - this one is a bitch to get to, in fact I just couldn't. However with a universal joint extension and a longer wrench it should be easy to get to:



And finally if you follow that same hose from the driver's side of the intercooler up the front of the engine, there are these two clamps. This is looking down on the engine from the top, standing on the passenger side:



I was able to get the driver's side (top) one by snaking my hand to the left and underneath that big L-shaped line in the foreground, but I couldn't get the bottom one as there was not enough clearance for the socket wrench. However you could easily get it with an open-ended 7mm wrench.
 

·
Registered
Joined
·
428 Posts
I put the car on jack stands and I was able to tighten every clamp except one of the throttle body clamps I couldn't get to. My clamps weren't loose but they weren't very tight. I'd say they were medium tightness but I tightened it up a little more and felt a slight difference.

Reason I did it was I noticed on my AP my max boost would only hit 21.17psi once then would always top out at 20.35psi after that. After I tightened all the clamps the boost hits a max of 21.97psi and hits 21psi all the time in every gear


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
21 Posts
Thanks for posting this up!

Did this to mine just the other night. The 10 clamps weren't necessarily loose, but they were all able to be tightened 1/2 turn pretty easily without overtightening. I don't have an AP to verify how much boost was being held before and after, but it seems to be slightly quicker..probably just a mind game though :/
 

·
Registered
Joined
·
186 Posts
All mine were a little loose. some more than ever. thanks for the pics. made it easy and fast to do.
 

·
Registered
Joined
·
141 Posts
Should I be worried about over tightening these? I cranked them all down with a ratchet until they wouldn't go anymore. I'm thinking I should put it on the ramps and double check them.
 

·
Registered
Joined
·
22 Posts
just out of curiosity, how many miles did you guys have when you checked these
 

·
Registered
Joined
·
545 Posts
Mine were loose from the factory. I tightened them at under 300 miles.

Sent from my Nexus 5 using Tapatalk
 

·
Registered
Joined
·
63 Posts
Thank You everyone for the info on the clamps. My Tuxedo Black ST was feeling a bit off when I read this thread. Put the car on ramps & every clamp needed tightening. I used a 7 MM racheting wrench.Car feels like it has more power. Thanks again everyone for the info & detailed pictures.

Sent from my LG-E980 using Tapatalk
 

·
Registered
Joined
·
54 Posts
Mine are loose almost every time I check them. Anyone have a link where I can buy better clamps? Does double clamping help?
 

·
Registered
Joined
·
728 Posts
Mine are loose almost every time I check them. Anyone have a link where I can buy better clamps? Does double clamping help?
Mountune sell the stainless steel pipe clamps for all the charge, induction and IC piping.

Sent from my GT-I9505 using Tapatalk
 

·
Registered
Joined
·
163 Posts
So this must be a pretty common problem on the ST's? I am now wondering if mine are loose. I bought mine just over 2 weeks ago and my MPG's are going down not getting better as i thought they would from the motor loosening up. I know conditions and how you drive make a difference. So would loss of boost. I am going to have to check all these this week and see
 

·
Registered
Joined
·
186 Posts
So this must be a pretty common problem on the ST's? I am now wondering if mine are loose. I bought mine just over 2 weeks ago and my MPG's are going down not getting better as i thought they would from the motor loosening up. I know conditions and how you drive make a difference. So would loss of boost. I am going to have to check all these this week and see
I would tighten all your clamps. Im sure some are loose. I gained mpg after I tighten them
 

·
Registered
Joined
·
301 Posts
I just decided to tighten them as a precautionary measure. I wasn't having any problems. They were still a tad loose like everyone is reporting.
 

·
Registered
Joined
·
152 Posts
I tightened mine about 4000 miles ago. Checked again a week ago and they were still tight.
At the autocross last weekend, a FoST had his intercooler pipe pop off during his first run. He said that was the second time it had happened.
 
1 - 20 of 28 Posts
Top