Ford Fiesta ST Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
298 Posts
Discussion Starter #1
The thing works good but keeps breaking on me. This time the bracket cracked. Been 6 days and 3 emails cause they don't work by phone. Seems there is a new bracket but i can't get a hold of anyone to help me out. Any ideas guys?

Sent from my SM-G930P using Tapatalk
 

·
Registered
Joined
·
93 Posts
The thing works good but keeps breaking on me. This time the bracket cracked. Been 6 days and 3 emails cause they don't work by phone. Seems there is a new bracket but i can't get a hold of anyone to help me out. Any ideas guys?

Sent from my SM-G930P using Tapatalk
I too have had issues, I find their chat line to work the best, though the most recent time had to bug them again on the chat line. My issue recently was the bronze filter in side the can came loose and damaged the screen filter. So they are sending me new parts to fix it.

Yes they have a new bracket design, though I'm only aware of one since they originally released the can. I have to install the new bracket as well, my bracket hasn't broke yet with probably 40,000km on the car since installing


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
298 Posts
Discussion Starter #3
Woo hoo! They ancwerd the phone today. My new bracket should be in the mail. That's the same thing that happens to me went to dump it and found some of the parts in the bottom of the can. They sent a new can without the hoses or a bracket. I wasent crapping on them here just frustrated. Looks like it's being taken care of now.

Sent from my SM-G930P using Tapatalk
 
1 - 3 of 3 Posts
Top