Ford Fiesta ST Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I've noticed a issue recently after swapping from a catless DP to my catted one for inspection. When idling, I'll see the RPM dip to around 600-700 or so, and it is always accompanied by the smell of gas or exhaust. I used to only see this after filling up, but now it is just happening intermittently. I thought maybe I hadn't tightened the cat bolts down enough, but it drives great, it's only at idle I see the issue.

I've read multiple threads on the idle issue after fill up (which has happened to me ever since I got the car), but none discussing the problem in general. I did see see a p1450 evap code before switching to stage 0, so will be trying the capless gas tank cleaning method today before purchasing a new fuel feed tube (Tube - Fuel Feed (D2BZ-9C047-E)|Tascaparts.com | TascaParts.com). Has anyone else seen this on their vehicles? Everything else works fine, it's just this one nagging issue lol I will be so happy when this is resolved. BTW it's a 2015 Fiesta ST. Thanks in advance.

EDIT: Adding this as an update for consolidation.

So I tried lubing the gas port and opening and closing a bunch of times and no dice after driving around the corner. I did notice on the AP, boost and afr seems to climb and coincide with the drop in RPM, very weird....Any thoughts?

Will replace EVAP system when I get the chance and maybe test for boost leaks.

If anyone has any ideas would be happy to hear. Really don't want to take my baby to $100 an hour boys
 

·
Registered
Joined
·
4 Posts
My 2019 had this same problem. Accompanied by a loud ticking sound coming from under the hood. The dealership replaced the evap part right on top of the engine. All stalls were fixed, and car doesn’t make that ticking sound now. My nose isn’t too good at smelling gas so idk if there was a gas smell. Keep and ear out for that obvious loud ticking at idle.
 

·
Registered
Joined
·
4 Posts
My 2019 had this same problem. Accompanied by a loud ticking sound coming from under the hood. The dealership replaced the evap part right on top of the engine. All stalls were fixed, and car doesn’t make that ticking sound now. My nose isn’t too good at smelling gas so idk if there was a gas smell. Keep and ear out for that obvious loud ticking at idle.
 
1 - 4 of 4 Posts
Top