Ford Fiesta ST Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
428 Posts
Discussion Starter · #1 ·
I did 4 runs, my best time was 6.989 sec. A perfect launch happened at 2500rpm with manageable wheel spin and on the edge of grip in second gear. Now since I'm 5400ft above sea level, turbo cars are 1 second slower at 5400ft then at sea level. 2 seconds slower for n/a cars. I like to think if I was at sea level I would have run a 5.989! My slowest time was around 8.5 seconds when I launched at 4500rpm and just sat there spinning tires for a second.

Tried to do a quarter mile run but I don't have the roads to do that much. I got 1 mediocre run at 15.3 sec @ 92.2mph, the 0-60 was 7.5 on that run.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
545 Posts
I'm pretty terrible at launching. Always have been :p I measured a little over 7 seconds stock but haven't plugged in my OBD2 reader since then.

I've never been able to hit or exceed a manufacturer's advertised time - not without mods, anyhow. Case in point I have no idea how they got 4.7s to 60 in my previous car (E46 M3), best I could muster was 5.2 or thereabouts. That said, given the COBB 93 tune, it's probably decently quicker to 60 than a stock one.
 

·
Registered
Joined
·
31 Posts
It's hard to duplicate performance benchmarks like that. First, many of the people who do the testing are professionals, and know the skills. Second,


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
31 Posts
Sorry...didn't finish. they also beat the heck out of the cars to get those times. You may not be willing to do the same to your car.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
946 Posts
It's hard to duplicate performance benchmarks like that. First, many of the people who do the testing are professionals, and know the skills. Second,


Sent from my iPad using Tapatalk
Ive always thought it was pretty easy to match or beat the "standard" numbers and I wouldn't call myself a professional, a good driver, but not a professional! I remember running my stock 04 Mach 1 at the strip and cranking out 13.1X's all day, while some of the other nodded ones were running 13.9+ lol. Just about getting familiar with it and a little trial and error to see what works!
 
1 - 5 of 5 Posts
Top